HUE-9482 [ui] Add queries interface in Job Browser

Review Request #15454 — Created Sept. 22, 2020 and submitted

Sreenath
hue
master
HUE-9482
hue
Amlesh1902, johan, ranade, romain, yingc
commit bcc38c15a1b85a615ca59005a36910c69c616b41
Author: sreenaths <sree@apache.org>
Date:   Tue Sep 22 17:57:37 2020 +0530

    HUE-9482 [ui] Add queries interface in Job Browser

:100644 100644 f31fd37b57 0509f1acea M	apps/jobbrowser/src/jobbrowser/conf.py
:100644 100644 f6b41b179f 4d92d44abe M	apps/jobbrowser/src/jobbrowser/templates/job_browser.mako
:100644 100644 3294fd1d14 0ab09ca38f M	desktop/conf.dist/hue.ini
:100644 100644 3dca8321b2 7a88406acc M	desktop/conf/pseudo-distributed.ini.tmpl
:100644 100644 52941f8bba 3d2352ed7e M	desktop/core/src/desktop/js/apps/jobBrowser/app.js
:000000 100644 0000000000 91384aed7a A	desktop/core/src/desktop/js/apps/jobBrowser/components/queriesList/queries-list.vue
:000000 100644 0000000000 b95bdf0ba3 A	desktop/core/src/desktop/js/apps/jobBrowser/components/queriesList/webcomp.ts

Manually tested

  • 3
  • 0
  • 0
  • 0
  • 3
Description From Last Updated
Any chance to just reuse ENABLE_HIVE_QUERY_BROWSER.get() ? (as it will duplicate things otherwise and better to unify sooner than later) romain romain
And then we can start having the mix of DAS proxy / new Hue API already (again, it will save ... romain romain
Note: cf. above comment, and using queries-hive is probably more explicit romain romain
romain
  1. Nice!

    Some comments on getting the Hive Query browser unified with the current one from the start?

  2. apps/jobbrowser/src/jobbrowser/conf.py (Diff revision 1)
     
     

    Any chance to just reuse ENABLE_HIVE_QUERY_BROWSER.get() ? (as it will duplicate things otherwise and better to unify sooner than later)

    1. As the queries would be used for both Hive and Impala down the line, was wondering if ENABLE_HIVE_QUERY_BROWSER would be confusing. Hence a more generic name - ENABLE_QUERIES_LIST

  3. And then we can start having the mix of DAS proxy / new Hue API already (again, it will save time to have both from the start)

  4. Note: cf. above comment, and using queries-hive is probably more explicit

    1. As the queries could be used for both Hive and Impala down the line, thought a more generic name might be better.

  5. 
      
romain
  1. Synced with Johan, let's go ahead, this flag is for the UI so!
    For the API we can do separately

  2. 
      
Sreenath
Review request changed

Status: Closed (submitted)

Loading...