Please turn it on in your browser preferences.
for specific sites, we recommend the
Review Request #2893
Created April 18, 2013 and submitted April 18, 2013, 5:55 a.m.
Implements URI prefix matching.
Unit tests added.
Awesome, thank you for the review!
Nit: It might be better to name the arguments as requiredKeyVal and requestedKeyVal. Now with the URI logic that order would matter.
That is a good change and I will do it on commit. It took me a while to get this straight in my head, but order always matters for both implies methods since what we are trying to arrive as is implication not equality. i.e. server=server1 implies server=server1,db=customers but the reverse is not true. Took me a little while to see this in the method since I am used to writing .equals().